Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[FIXED] Current problems with ModEnc
#1
As most of you may have noticed, ModEnc currently seems to have some problems ending in "infinite loop" error messages.
I have traced this down to a bug in the rewrite-engine, probably introduced by a PHP-upgrade by the host.


ModEnc is still fully functional, just not as automagically as usual.

URLs like
http://www.modenc.renegadeprojects.com/index.php/Weird_Bug do not work, while URLs like
http://www.modenc.renegadeprojects.com/index.php?title=Weird_Bug do work.

We're trying to get rid of this problem asap.
Forum Rules

(01.06.2011, 05:43:25)kenosis Wrote: Oh damn don't be disgraced again!

(25.06.2011, 20:42:59)Nighthawk Wrote: The proverbial bearded omni-bug may be dead, but the containment campaign is still being waged in the desert.
Reply
#2
Problem solved.

Cause: 'Pretty' URLs ("## If using PHP as a CGI module, use the ugly URLs" - According to the documentation, they are incompatible with running PHP as CGI module, which is exactly what the host is doing. Eww. )
Solution: .htaccess voodoo (now it transparently overwrites all 'pretty' URLs with 'ugly' ones). You can now use both 'pretty' and 'ugly' URLs properly.

I believe this gets around the CGI mess, but if you still experience errors, reply here and I will try to resolve it in a different way.

Note:

'Pretty' URL : http://www.modenc.renegadeprojects.com/i.../Weird_Bug
'Ugly' URL: http://www.modenc.renegadeprojects.com/ind...title=Weird_Bug
Reply




Users browsing this thread: 1 Guest(s)